Announcement

Collapse

Welcome to ShoreTelForums.com

Welcome to ShoreTelForums.com!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel systems. ShoreTel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel, Inc. although you may find ShoreTel employees sharing there experiences and expertise. If you would like more information on ShoreTel systems, contact BTX at info@btxchange.com

Thank You
BTX
See more
See less
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ShoreTel Support

    I've been working with the ShoreTel products either as a partner or customer for 10 yrs now and over the years their support has slowly gone downhill. I have called 3 separate times today, spent over 2.5 hours on the phone and still no answer. In the past, the incident managers would al least pick the call out of Queue if needed and greet me take some notes and tell me they are all on downed systems, but now I guess they just leave people in queue.

  • #2
    TAC response times have spiked in the last couple of years. I suspect, as an outsider looking in, that this is because they underestimated the demand on TAC from cloud customers. Usually I do not get it as bad as you are describing, but I have once or twice. Sometimes chat works to get a response started earlier, but you have to remember that the chat agents cannot call you, if you need a call you have to wait in a voice queue. I feel your pain and am keeping my fingers crossed that ShoreTel does not keep on the curve that it is presently on...

    Comment


    • #3
      Same issue here in the UK. Seems all the focus is on Cloud Connect. I'm on 19.47.5900 and I'm getting to the point where I'm just not bothering to try and log anything anymore. We have initiated a review of the whole solution as it's just not good enough.

      Standard response to anything is Upgrade... CBA...

      Comment


      • #4
        I'm right there with you man, also been doing it since 2004, and it has been going downhill (in my opinion since about 2011).
        I dread it when I get to the point where I have to open a TAC case.

        Comment


        • #5
          Oh, and the fact that there is no local or toll free number for me to call, it hurts when I have to make an international call and then sit in the queue for an hour or more...

          Comment


          • #6
            Shortest wait time on hold in the past 7-8 months - 45 minutes and that was at 2AM!! Trying to get in using the T2 code, is the same....bad.

            Comment


            • #7
              A friend of mine recently registered for this forum, he's wasn't able to post anything since he was looking to ask something about the system. It took quite a while before his account got authorized.

              Comment


              • Lance
                Lance commented
                Editing a comment
                This usually happens due to the registration emails not being completed by the end users or confirmation emails not being completed.

            • #8
              Originally posted by Mike Cartwright View Post
              A friend of mine recently registered for this forum, he's wasn't able to post anything since he was looking to ask something about the system. It took quite a while before his account got authorized.
              And that's relevant to this conversation how?

              Comment


              • Lance
                Lance commented
                Editing a comment
                This site is not owned, funded, or managed by ShoreTel, Inc

            • #9
              Mike seems to be trying to get his post count up, so he can keep spamming us.

              Comment


              • #10
                Have to agree with you guys regarding support, gone to sh1t over the last few years.

                I had a problem with a recent 14.2 upgrade to Connect (3 sites in different countries), after three weeks, there was an issue with phones registered to an SG90 in one site. TAC's answer was to DOWNGRADE to 14.2. I kid you not. I made some changes in the database myself and got it back going, but these guys are off their heads if they reckon that it was viable next step.

                Couldnt even get to talk to the "escalations engineer" of the Tier 1 guy I was talking to.
                Last edited by Keithtmurphy; 07-26-2017, 08:18 AM.

                Comment


                • #11
                  I agree, it isnt what it used to be.

                  Comment

                  Working...
                  X