Announcement Announcement Module
Collapse
No announcement yet.
ShoreTel IM Not Working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ShoreTel IM Not Working

    Hi guys

    I've setup my SA100 successfully and this is the first time I'm setting up IM. I've setup myself and a colleague on Director to use the SA100 for IM.

    I can see that we are both online on Communicator but the "IM" is greyed out. Further more, when I go to Tools>Options>Instant Messaging, Sign-in name: has already got my email address but is greyed out and can't be changed. Password is blank and is also greyed out and can't be changed. The last part "Advanced Options:" My domain user name and Instant Messaging sign-in name are not the same. Please use the following user name. "User name:" is also greyed out and can't be changed.

    Has anyone got any ideas on setting up IM on SA100?

  • #2
    Are you using active directory authentication?

    Comment


    • #3
      Originally posted by aj1104 View Post
      Are you using active directory authentication?
      Thanks for replying mate

      At the moment I don't use AD authentication on ShoreTel but I do use AD authentication on my domain

      Do I need AD authentication on ShoreTel?

      Comment


      • #4
        No you should not have to use AD authentication to make the IM work. You can try it to see if it makes a difference. Have you verified that the service are up in IM server maintenance. see attached screenshot
        Last edited by aj1104; 09-24-2012, 04:42 PM. Reason: new screenshot

        Comment


        • #5
          Originally posted by aj1104 View Post
          No you should not have to use AD authentication to make the IM work. You can try it to see if it makes a difference. Have you verified that the service are up in IM server maintenance. see attached screenshot
          Thanks for replying mate. I've checked all services on the SA100 and there is Web Server (Running), Collaboration Management Conference Attendant (Running), Software Telephony Switch (Running), Telephony Management Server (Running) and under IM Status I've got IM Server (Running)

          Attachment

          One more thing I want to confirm is the "Domain name" entry on the SA100 stcli config. Is it the FQDN of the SA100 itself or the domain that all my PCs are on? I really need to make this work guys....Please share your experiences
          Attached Files

          Comment


          • #6
            The Domain Name can be anything you like, it gets appended to the back of the client user name.
            If you make that match your email domain, and make sure that the client username matches the user part of your email address, then the presence works in Outlook 2007 and upwards.
            I don't quite understand why you are having such a hard time getting the SA-100 to work, it should take no more than a couple of hours. I recently retired an old unified conference bridge in favour of an SA-100 for a large organisation and it took me a morning, a lot of that was trying to get the old Web certificate installed on their new SA-100, but the basics were no bother at all.

            Have you looked on the ShoreTel training central at the Unified Communications Administration training courses?
            There is a bunch of free ones and they cover the installation and administration of an SA-100. One of them is a self paced pre-recorded session so you don't need to stay awake all night to do one of the instructor led ones.

            Comment


            • #7
              Someone else with more helpful information please?

              Comment


              • #8
                My apologies I'll try and be more helpful then:

                Make the domain name in System Parameters -> Other the same as the one you use for your email address.
                The domain name that might be in use on the network settings on stcli would normally be the one that you use for devices on your network, this is so that DNS works and nothing to do with routing the IM's.

                In the Telephony class of service there is an option IM Presence Invitation Handling: change this to Auto Accept (for the purposes of testing)

                In Communicator go to Options -> Instant Messaging -> Presence and use the Separate Telephone and Instant Messaging Presence (this makes it easier to see that they are both working in the Contact tab if Commuicator)
                There will be a button on the toolbar next to where you change your call handling mode which should say Online and be green. This needs to be green on both communicators, if you can't make it go green you need to look at connectivity between the Communicator client and the SA-100.

                In your contact tab in communicator (in ShoreTel 12 you need to be using at least Professional Communicator) add your colleague if they are not there already.
                You should see two blobs next to their name, one for their telephony state and the other one for IM. They should both be green. If the IM one is grey then this is a sign that they are not logged into the SA-100 or they are not currently running, there is also the status option that makes them appear offline.
                When you right click you should get the IM option near the top of the list. Is this the bit that is grey, on mine it's there if they are online but doesnt show at all when they are not available?

                Comment


                • #9
                  make sure your IP Address MAP includes the IP address range of the PC's using IM

                  Comment


                  • #10
                    Originally posted by GulfStatesSE View Post
                    make sure your IP Address MAP includes the IP address range of the PC's using IM
                    Thanks so much for replying mate........Your single line reply has solved the one problem which has been bugging me for weeks now.....Much appreciated

                    Just need clarification here....should I add a new Address Map entry to the same site as the SA100 or Parent Site where the HQ Server sits? I've tried adding it to the site where Conference Bridge is located at and I'm getting error "Warning! Site: 'Conference Bridge' does not have any configured switches with IP Phone Ports."

                    However if I just ignore this error, everything works fine.

                    Comment


                    • #11
                      Should the PC ip address ranges be in an IP Phone Address Map entry, or should they be in the Trusted IP Range? Or both?

                      Comment


                      • #12
                        Originally posted by rca View Post
                        Should the PC ip address ranges be in an IP Phone Address Map entry, or should they be in the Trusted IP Range? Or both?
                        I just added the PC IP Address range to the Parent Site under IP Phone Address Map and everything works like a charm

                        Comment


                        • #13
                          Originally posted by shoretelghst View Post
                          I just added the PC IP Address range to the Parent Site under IP Phone Address Map and everything works like a charm
                          Hi there,

                          Am having the same exact problem over here with the SA-100 and IM services...i actually had it working once but went down after 1 hour or so without even touching a thing..

                          I had documented my settings but even if I try to replicate them exactly, I can't get IM working...only thing i get is "Lost IM connectivity, reconnecting..."..

                          I've spent about 3 weeks trying a lot of settings and moving back & forward between them all but still no luck.

                          I'm just curious to see exactly what needs to be setup for:

                          a) in the CLI for domain name: do i need to put down just the domain (ex. company.com) or FQDN (ex. sa100.company.com)

                          b) in the CLI must i use an internal DNS server that resoves the FQDN to the SA100 local IP? (I already have this setup now)

                          c) in "System Params -> Other" under "IM Domain", if you click on the "Help" link in Director it says you need to put down the FQDN (ex. sa100.company.com); However, ShoreTel Dave advised to put down only the domain name (ex. company.com) ????

                          d) when assigning a name to the SA-100 in Director does it need to match the host part of the FQDN? For example, set the name up as "sa100" and Description as "Conference & IM bridge"

                          e) my SA100 is at a branch site (not HQ) but only users at this site will be using it at the moment; I already have an IP Address Map setup for this site's PC (we were using some SIP phones and this was the only way to register them to the local Proxy and not the one at HQ). I see this worked for you but it's not doing the trick for me...maybe am overlooking something else??

                          f) when i assign a user to use the SA100 for IM, does his "e-mail address" in Director need to match the full string that's showing up in Communicator -> Instant Messaging -> Sign-in name ??

                          I'm really annoyed with this thing and the manual doesn't help at all... I would be very grateful for any piece of advice that you might have to share... If you could provide some screenshots from CLI, System Params so that i can compare, that would be super.

                          Many thanks gents.

                          Comment


                          • #14
                            Answers to some of your questions:

                            a) in the CLI on the appliance, the domain name is just the domain, ex. company.com
                            b) yes
                            c) in ours, it is set to just the domain, ex. company.com
                            d) in ours, our Director 'Name' for the appliance does not match the FQDN
                            e) I added the ip range in System Parameters/Security/Trusted-IP-Ranges. Since my last post I've found that I can have PC's that are in the trusted ip range but not in the ip phone address map, and IM still works
                            f) I think the answer is no. In my Communicator, the IM sign-in name is greyed out (I'm using AD authentication) but it shows my AD login name, not my email address.

                            Comment


                            • #15
                              Hi rca,

                              I really appreciate your taking the time to share this information with me. I've tried setting this one up again from scratch but I still haven't managed to get it up & up. I'll keep trying though & will post here if and when i fix it.

                              Thanks again.

                              Comment

                              Unconfigured Ad Widget Unconfigured Ad Widget Module
                              Collapse
                              Working...
                              X